Child pages
  • Upgrading from SNMP4J 2.x to 3.x
Skip to end of metadata
Go to start of metadata

The following changes need to be considered when upgrading from SNMP4J 2.x to 3.x:

  1. SNMP4J 3.x requires Java 9 or later (for the DTLS support)
  2. In version 3.x the following security protocols are no longer available by default: AuthSHA and AuthMD5. To add them call

    SecurityProtocols.addAuthenticationProtocol(new AuthSHA());
    SecurityProtocols.addAuthenticationProtocol(new AuthMD5());
  • No labels